fbpx
Cliquez ici pour découvrir les 7 étapes pour créer
des tableaux croisés dynamiques comme un pro sur Excel

Tutoriel réalisé avec Excel 2013

Grâce à Excel, vous pouvez compter le nombre de caractères (lettres, chiffres, signes de ponctuation, espace…) de manière automatique de différentes façons.

Pour compter le nombre de caractères avec Excel, vous utiliserez la formule NBCAR.

 

Compter le nombre de caractères d’une chaîne de caractères saisie :

Cette formule peut être utilisée sans référence à une cellule. Vous commencerez donc la formule par =NBCAR(). Entre parenthèse et entre guillemets, vous saisirez votre chaîne de caractères comme dans cet exemple :

=NBCAR("Votre Assistante")

Ce qui vous donnera : 16

 

Compter le nombre de caractères présents dans une cellule :

Placez-vous sur une cellule vide d’Excel et saisissez la formule suivante :

=NBCAR(A1)

A1 étant la cellule où se trouvent les caractères à compter.

 

Compter le nombre de caractères présents dans une cellule sans les espaces :

Pour qu’Excel ne prenne pas en compte les espaces dans une chaîne de caractères lors de son calcul, vous devrez utiliser la formule SUBSTITUE. Celle-ci fonctionne de la même manière que lorsque vous utilisez la fonction Rechercher-remplacer d’Excel. Nous allons donc demander à Excel de remplacer, dans son calcul, les espaces par rien afin que la formule NBCAR effectue son calcul pour le reste des caractères.

Voici la formule à utiliser pour compter les caractères de la cellule A1 :

=NBCAR(SUBSTITUE(A1;" ";))

 

Compter le nombre de caractères présents dans une plage de cellules :

Pour cela, vous utiliserez la formule SOMMEPROD. Celle-ci va calculer la somme suivant un critère. Ce qui donnera cette formule pour calculer la plage de cellules A1 à A3 :

=SOMMEPROD(NBCAR(A1:A3))

 

Téléchargez « Compter le nombre de caractères avec Excel (formules nbcar, substitue et sommeprod) » au format PDF

Cliquez ici pour découvrir les 7 étapes pour créer
des tableaux croisés dynamiques comme un pro sur Excel
nunc ipsum libero. ut efficitur. id id adipiscing Praesent tempus consectetur accumsan