Inscription à la newsletter

Tutoriel réalisé avec Excel Microsoft 365

Dans le tutoriel sur la réinitialisation d’une liste déroulante en cascade sur Excel, nous avons vu que nous pouvions, pour une meilleure expérience utilisateur, vider le contenu de la cellule de la seconde liste si la première liste était modifiée et, cela, avec du code VBA (Visual Basic for Applications). Toutefois, il est aussi possible d’indiquer à l’utilisateur qu’il doit d’abord sélectionner un élément dans la première liste avant de sélectionner un élément dans la seconde et c’est ce que nous allons voir dans ce tutoriel dans lequel nous allons utiliser le fichier du cours sur la création de listes déroulantes en cascade avec Excel.

 

Définition du texte à faire apparaître si la liste précédente est vide

Pour cet exemple, dans la feuille nommée Feuil1, si un pays n’est pas sélectionné en A1 et que l’utilisateur clique sur la liste déroulante des villes en B1, je souhaite que celle-ci contienne uniquement l’élément Sélectionnez un pays et non pas que cela donne l’impression que quelque chose ne fonctionne pas.

Pour cela, dans une cellule quelconque du classeur, je saisis Sélectionnez un pays. Puis, je nomme cette cellule, via la Zone Nom, Pays_vide et j’appuie sur la touche Entrée :

Nommer une cellule Excel Pays_vide

 

Modification du contenu d’une liste déroulante en cascade si la précédente est vide

Pour rappel, la formule qui permet de filtrer une liste déroulante selon une autre pour une liste en cascade est :

=INDIRECT(A1)

Où A1 est la cellule où se trouve la liste de premier niveau :

Validation des données Excel Indirect pour cascade

 

Pour que la seconde liste ne fasse apparaître que le texte que j’ai défini dans la cellule nommée Pays_vide, j’imbrique une fonction SI :

=SI(A1="";Pays_vide;INDIRECT(A1))

Celle-ci permet d’afficher ce qui se trouve dans Pays_vide si A1 est vide :

Validation des données Excel Si et Indirect pour cascade

Cliquez sur OK, puis testez votre liste sans pays :

Liste déroulante en cascade Excel vide

Et avec pays :

Liste déroulante en cascade Excel Pays-Villes

 

Notez que la cellule nommée Pays_vide peut être masquée si elle ne sert qu’à la formule.

 

Vous retrouverez le fichier utilisé dans l’Espace Membres accessible aux abonnés à la newsletter.

Inscription à la newsletter